Friday, December 05, 2014

Microsoft Exchange Trials and Tribulations of on OS X Yosemite

I have been a long time user of on OS X. It goes through it’s ups and downs. While on Mavericks there seemed to be real issues with gmail. It was a case of mail deja-vu. You would delete an email and it would magically re-appear. I recently upgraded to OS X Yosemite and seemed to be working well. That was until I needed to connect to an Exchange server,

I have successfully linked my iPhone running iOS 8 to the exchange server. Sending and receiving email works fine for exchange on iOS as far as I can tell. However, After adding the Exchange Server in and through the Internet Accounts section in System Preferences I can successfully access my Exchange Calendar. Mail is a different story. steadfastly refuses to recognize the Exchange account. The setup process works and the account is recognized but the Exchange inbox will not come up in the list of mailboxes.
I have tried to configure using the “Other” Option but using IMAP fails. And now refuses to let me delete the “Other” account.

I even closed and went to ~/Library/Mail/V2/MailData/Accounts.plist and found the bad entry. I deleted it from the plist file but the imap item is still lurking. Trying to delete it and you get the error:

Account removal failed with error: “The operation couldn’t be completed. Unable to find an account for the UID given.”.

It looks like the only options on Mac OS X Yosemite for exchange is to use the Exchange OWA web client through the browser, or use Outlook for Mac. These options do work. I hope Apple sorts out these Exchange issues in an update to 10.10.1 because is currently broken for Exchange users. It is apparent that I am not alone in this check out the forum messages here:

via WordPress